Differences

This shows you the differences between two versions of the page.

Link to this comparison view

phelp:notetips3 [2013/12/03 12:30] (current)
Line 1: Line 1:
 + MARC Report Tips -- Formatting instructions
 +
 + Use a Text Editor to edit this file. 
 +
 + The filename must be \Program Files\TMQ\MARC Report\Help\NoteTips3.txt
 +
 + Empty lines, or lines that begin with blankspaces, or tabs (like this one), are ignored.
 +
 + Each Tip must occupy on a single line; turn off Line Wrap to make this more apparent
 +
 + Each Tip should contain no more than about 530 characters 
 +
 + Tips edited while the program is running are ignored.
 +
 + Most important: If you customize this file, backup your changes in a different folder: 
 + NoteTips is overwritten by each new version of the program.
 +
 +
 +This first time you use MARC Report, we recommend that you advance through a few records in this mode and read the Hints that appear in this window. These hints contain instructions for the most common MARC Report questions. Once the hints begin to repeat, you know you have seen them all.
 +
 +There are several different ways to run MARC Report. The record browser view you are now seeing allows you to either edit each record in a file (something we call an 'Edit Session'), or to page through the records in read-only mode (something we call 'Record-by-record' mode). Another option is to use 'Batch mode', which quickly scans the file and produces an error report. Most of the hints that follow assume you are in 'Edit' mode.
 +
 +When using the record browser, the default display is the MARC record view (the other views will be described shortly). In this view, there are four separate panels: the main panel contains the complete record, the top panel contains the leader and fixed fields, the top right panel contains the Brief messages (ie. a list of cataloging problems in the current record), and the bottom right panel contains the Notes.
 +
 +When you click on a Brief Message in the list above, the program will position your cursor on the problem in the MARC Window (on the left), and display more information about the problem in the Notes Area (this space). If there are no messages above, but a picture instead, then, Well done! -- the program could find no problems in the record and has rewarded you with a perfection image :-) (Simply click on the image to return to the 
 +
 +The MARC view is highly customizable. You can: resize the program window by dragging the sizegrip at the bottom right of the form; resize the fixed field panel by dragging the blue bar beneath it; resize the brief messages/notes area in the same way; and completely collapse (or expand) both of these areas by clicking the long narrow '>' button in the center of the corresponding blue 'splitter' bars.
 +
 +The main MARC window displays the record data in four columns: column 1 contains the tag, columns 2 and 3 contain the indicators, and column 4 contains the data. The narrow gray cells to the left of the Tag simply point to currently active field. However, when you click on it, the complete data for the corresponding field is selected--its an easy way to clear a field when you are editing. An optional column containing a tag occurrence number can be displayed by selecting the associated option (on the Record Display options page).
 +
 +To edit data in MARC View, simply on the field and begin typing. If clicking a tag or indicator, the complete cell is selected, thus any typing will overwrite the contents. If clicking a data field, the program positions the cursor at the point of the mouse-click. The usual windows shortcuts are available in data cells: <Ctrl>A, <Ctrl>C, <Ctrl>V, <Ctrl>X, <Ctrl>Z (Select all, Copy, Paste, Cut, Undo). Note that MARC Report also has an Undo button (bottom left) which will restore any edited record to its original state in the file.
 +
 +To add a new tag, click on an existing tag cell in the MARC window, press the <Insert> key, and type the three-digit tag. Use the TAB key to move the cursor to the next cell, eg. Indicator 1, Indicator 2, etc. To add a subfield delimiter, type <Ctrl>D, followed by the subfield code. To delete a tag, click on the tag cell then press the <Delete> key; the tag (and all of its data) will be removed the next time you press the 'Save' button (on the bottom left).
 +
 +To edit an existing fixed field, simply click on the appropriate button in the fixed field panel at the top. By default, the Leader should now be displayed in that area. Press the 008 button: the fixed field panel will switch the display to the 008 elements. The shading of the fixed field buttons indicates which one is currently selected (the selected field will be  inverse to the others).
 +
 +To add a new fixed field, click on the fixed field button for the tag you want to add. This will clear the fixed field area and activate the template menu on the top right. Open the template menu (by clicking the down arrow) and select the template for the type of fixed field you are adding: the program will use your template selection to set the first element of the new field, and add it to the record. You should then complete the coding for the field in the fixed field panel.
 +
 +If the record already has an 006 or 007, and you want to add another one, select the 'Add new 006' or 'Add new 007' option from the Edit menu; alternately, you can use the corresponding shortcuts <Shift><Ctrl><F6> and <Shift><Ctrl><F7>. Then select a template and complete the field as described in the previous hint. (Note: these additional menu options are required because clicking the 006 or 007 button on the fixed field panel will always display the first occurrence if there is one)
 +
 +There are several alternate record views available in MARC Report. Each view is represented by a tab along the left side of the screen: to switch a view simply click on the tab for the view you want to use. We will describe each view separately, but for now just note that the navigation arrows at the bottom of the screen remain fixed--so you can go forward and backward through the file in any view.
 +
 +To view the current record in a text editor, click the Text View tab on the left-hand margin. When you do this, the Brief Message/Note panel may automatically collapse (as that is the default for a text view); you can restore this panel by clicking the long narrow '<' button in the middle of the blue bar. Try it: Click the Text View tab on the left, then re-open this panel.
 +
 +Text view is useful for editing long fields (eg. 505s), deleting large numbers of similar fields (eg. holdings fields), and copying and pasting large amounts of data (eg. 520s). However, there are a few quirks about Text View (as the data is more or less completely unstructured--unlike the MARC View), so be sure to read the Text View Help (bottom right) the first time you edit records here, so that you are aware of the caveats when editing MARC records in this mode.
 +
 +MARC Help is available for any data element in MARC View: click on the tag, indicator, or subfield that you want help for, and press <F1>. For fixed field help, click in the data element in the fixed field panel, then press <F1>. Since fixed field elements are typically derived from codes in value lists, MARC Help makes it easy to edit these hard-to-remember elements: click on the fixed field element you want to change, press <F1>, select the new value from the Help list, then press the 'Change' button to replace the existing value.
 +
 +MARC Help (F1) will display the complete MARC Code and Value lists for any relevant data element. For example, to view the 'MARC Code List for Languages', press the 008 button, click in the Language element (Position 35), then press <F1>. Or, to view the 'MARC Code list for Relators', click on any author tag, press <F1>, scroll to the bottom of the window, then click the [+] button on the left to expand the list of relator codes.
 +
 +Use the web link buttons that display in MARC Help (F1) to navigate to more complete information. The documentation provided by the Library of Congress and OCLC includes many useful examples of MARC coding, while the documentation in the RDA Toolkit provides many un-coded examples.
 +
 +To add a diacritic character to a record you are editing, position the cursor, press <F3>, select the appropriate character from the list that pops up, then press OK. (Remember that you may need a special font installed on your computer to view these characters as they would appear in another language.)
 + 
 +To view foreign script or diacritics in a record, use XML View. This will display the record in a browser window (Internet explorer, to be precise) using an encoding which supports the unicode standard. This function is useful if your records contain unicode data or 880 fields. If the 880 fields are MARC-8 encoded, they are converted to UTF-8 before they are converted to XML.
 +
 +Right-click on a brief message above to view the Cancelled Messages menu. You can use this feature to 'cancel' error messages you do not want to see, or to view messages that have been cancelled by your current settings. For more information, right-click and select 'Help on Cancelled Messages'.
 +
 +When editing, you can add records to your file from the Library of Congress catalog using the Import function. The basic steps are: Browse to the LC catalog, find the record you want, display the record with MARC tags, copy the complete record, then press <F9>. For more details and alternate steps, press the Help button in an Edit Session.
 +
 +When navigating through a file of records, a picture will appear on the right side of the screen whenever the program finds no problems in the record. We call this the 'Perfection' image. You can add your own perfection images to MARC Report by adding them to the 'Images\Perfect' folder in your MarcReport directory (in My Documents). To restore the right panel just click on the picture; this might be necessary to get back to a 'Find Next' search.
 +
 +You can save any record in the MARC window to another file simply by pressing <F6>. You can email any record in the MARC window simply by pressing <F7>. The MARC record is sent as a file attachment, and therefore can be loaded into any program that recognizes MARC records. You can copy any record in the MARC window to your Clipboard by pressing <F8>; the clipboard format as exactly the same as the one you will see in Text View.
 +
 +To customize the program, click 'Options' on the main menu. The options are grouped into pages, each focusing on a different aspect of the program. Use the options to: change the default MARC file, change the font, enable/disable cataloging error messages, create macros to use when editing, etc. Each page has a 'Help' screen which explains how everything works.
 +
 +To find out when a new version of MARC Report is available, you can: 1) Turn on the automatic Update Notification feature in the Program Automation options; 2) Click 'MARC Report update' under the Help menu 3) Visit the following URL: http://www.marcofquality.com/mrtsupport.html
 +
 +To turn off these tips, uncheck the option 'Display Tips in Notes area' in the 'Record Display' section of the program 'Options'. To edit these tips, use Notepad or Wordpad to open the file called 'NoteTips.txt' in the program's 'Help' directory (\Program Files\TMQ\MARC Report\Help). Read the formatting instructions at the top of the file.
 +
  
phelp/notetips3.txt · Last modified: 2013/12/03 12:30 (external edit)
Back to top
CC Attribution-Noncommercial-Share Alike 3.0 Unported
Driven by DokuWiki Recent changes RSS feed