Differences

This shows you the differences between two versions of the page.

Link to this comparison view

phelp:helpmainmenu [2013/06/18 11:35] (current)
Line 1: Line 1:
 +USING THE MAIN MENU IN MARC REPORT
 +
 +TMQ's MARC Report makes it possible for you to quickly and easily view, validate, edit and generate custom reports using USMARC data files of any size. These help notes describe the main menu of MARC Report.
 +
 +
 +THE FILE MENU  (Alt-F)
 +
 +Use the File menu to select the MARC file that you want to work with, and then to select the task that you want to perform on that MARC file.
 +
 +Select MARC
 +
 +Selects the MARC file to work with. When you select a file, the program automatically tests that it is a valid USMARC file, and displays an error message if it is not. Once a MARC file has been selected, it becomes the target file for all subsequent RUN and UTILITY options (until another MARC file is selected.)
 +
 +Reopen
 +
 +Re-select a MARC file that you previously worked with. The program remembers the last 10 MARC file selections made.
 +
 +Make Default
 +
 +This will make the currently selected MARC file the default, which means that whenever you start MARC Report, this file will be automatically selected (and you can then proceed to perform one of the program's many actions on it).
 +
 +
 +Once you have selected a file, the next step is to select an action to perform on it. You can select one of the following three actions, or any of the tasks that appear under the Utilities menu:
 +
 +1. Record-By-Record: Displays each MARC record in a large window, and displays brief validation messages and cataloging notes in two smaller windows on the right. A navigation bar makes it easy to jump to any record in the file, or to skip through the file stopping at all records with a certain problem. 
 +
 +2. Batch Mode: Processes the entire file and generates a report of all validation and cataloging errors (according to the options for this mode).
 +
 +3. Edit Session: Record-by-Record mode with an Edit capability added to it. 
 +
 +Both Record-by-Record and the Edit Session modes each have their own detailed Help screens.  Batch mode is more fully explained in the Help on the Batch Report options page.
 +
 +
 +New MARC File
 +
 +Creates a new MARC file (with whatever name you give it), and then opens the Editor. The first screen that displays is a brief record explaining that the file is empty and that you can add records to the file (this brief record is never saved). Any records that you add (using the Import MARC function under the Edit Menu) will be saved in the 'New' File that you created.
 +
 +
 +Edit Templates
 +
 +Opens a dialog for your MARC record templates. If you have not created any templates, only the DEFAULT will appear in the dialog.
 +
 +Print
 +
 +Prints the current MARC record (optionally with any messages). This option is only available when in Record-by-Record or Edit modes.
 +
 +Recover Edit Session
 +
 +If your computer crashes while editing a file of records, it is possible with this option to recover your lost work. Note: even if this option fails, if you are at risk of losing a large amount of work, please call TMQ for support; its often possible to restore an Edit Session using the workfiles that are created for each record.
 +
 +Exit
 +
 +Exits the program. You can also exit the program by clicking in the 'X' at the top right corner of the screen.
 +
 + 
 +THE EDIT MENU (Alt-E)
 +
 +These options are available when running the program in Record-By-Record or Edit mode.
 +
 +Display LC version of record/F4
 +
 +If the record contains an LCCN, press F4 to display LC's copy of the record. This feature uses the permalink service to download the record from LC and display it in a separate window. The record can be displayed in several different formats, and can also be compared to the current record open in MARC Report.
 +
 +Display current record in XML window/F5
 +
 +If the record contains diacritics or unicode which do not display correctly in the MR window, press F5 to display the record (using an Internet Explorer module) as XML, which provides complete unicode support. Note: If pressing F5 fails to display the record, it means there is an encoding error and the IE module choked when it tried to render the record. We will try to add a more helpful message to the program about this error in the future.
 +
 +Add/Append current record to a MARC file/F6
 +
 +Use this option to copy and paste the current MARC record to a MARC file. The program will prompt you for a filename, and if the file already exists, you can either append the record to the file, or overwrite it.  Since records copied in this way are saved in USMARC format, you could later run MARC Report on them (or any other program that requires USMARC records).
 +
 +Email current record as an MARC File attachment/F7
 +
 +This option will open an email form, and add the current record as an attachment to the email. You can then enter any email address, and the message will be set using your default email settings (if you are using a version of Outlook). Since MARC records are essentially binary files, this is the safest way to send a record to someone (like us, if you have a question or want us to check something for you).
 +
 +Copy current record to clipboard--as text/F8
 +
 +Use this option to copy the current MARC record to your clipboard. You can then paste the results into any text file.  You could use this option if you wanted to gather some records as examples for printing, instead of printing them one at a time. You can also use this option to paste the record into another MARC Report session (see 'Import MARC' below), into an email message, etc.
 +
 +Import MARC record from clipboard/F9 --Edit mode only
 +
 +Use this option when you want to copy a MARC record being displayed on another screen (like a web browser) into a MARC Report Edit Session. Currently, this type of importing works only with records from the Library of Congress catalog (http://catalog.loc.gov) or with some Z39.50 displays. However, you can also use this option to import a MARC record that you copied to the Clipboard using MARC Report. For more details on importing, please read the Help in an Edit Session. This options is only available in Edit mode.
 +
 +Open record in Text editor/F10
 +
 +Use this option to edit the record in a Notepad-like editor. This option is useful for editing large records with many repeated fields, records with very long fields, and records with fields that contain no blank spaces in them--all of which do not display very well in the default view used for editing. This is also the best way to copy and paste large amounts of data from one record to another. Note that although this option is available in Record by Record mode, changes to a record will only be recorded if in Edit mdoe.
 +
 +Add new record--from template/F11
 +
 +This option will open a dialog for your MARC record templates. Whatever template you select will then be added to the end of the current file. You can then edit the template and save it to the Edit Session.
 +
 +Save current record as template/F12
 +
 +This option allows you to save the currently displayed record to your templates folder.
 +
 +
 +THE VIEW REPORTS MENU  (Alt-V)
 +
 +Use this menu to view a list of reports that have been generated using MARC Report. The program remembers the last 9 reports that have been generated. At the bottom of this list will be the 'Title List', which is a list of the record numbers and titles for all of the records in the currently open file. The Title List can be customized--see the Help under the Program Automation options for details.
 +
 +
 +THE OPTIONS MENU (Alt-O)
 +
 +The Options consists of seven pages or 'tabs', each of which deals with a different group of program functions. Detailed help is available on each of these pages. 
 +
 +The seven option pages available are:
 +
 +Files and Directories
 +
 +This is where you can tell the program where to look for your MARC files and where to save your reports, and which MARC file to load by default. This is also where you would select the picture that displays when the program opens.
 +
 +Record Display
 +
 +This page lets you configure how MARC records will appear on your screen when running in Record-by-Record or Edit mode. You can choose whether MARC tags should be sorted or not, whether tag occurrence numbers should be displayed, which character should be used to indicate the MARC subfield delimiter (ASCII 31), and which font should be used for the MARC display.
 +
 +Cataloging Checks
 +
 +On this page you can enable or disable whether MARC Report runs cataloging checks, checks for filing indicator problems, checks for ISBD punctuation, checks for Mandatory fields, and checks non-fiction records for Subject headings. This page also launches editor that let you disable/enable individual checks for Common Cataloging problems and Mandatory fields.
 +
 +Validation 
 +
 +Here is where you may select which validation tables will be loaded; you can also select one or more filters (e.g. Ignore 9xx tags during validation) which can be applied to the validation tables. Or, you can use the Local Data editor to create your own validation table!
 +
 +Batch Reports
 +
 +This page is where you set the options when running MARC Report in Batch mode. You can choose to display statistics only (ie a list of error messages followed by the counts each occurred in the file), or to display the MARC field followed by a brief, or a detailed, message. You can also set what tag is used as a control number in these reports, and organize reports either by record or by problem (requires an extra sort). 
 +
 +Edit Sessions
 +
 +Configure how records are saved (eg. save all records whether changed or not), how Edit Results are named (eg. use the name of the source file), where Edit Results are saved, the default filenames for Edit Results, whether deleted records should be saved to a separate file, and how often Edit work files should be cleaned up. 
 +
 +Edit Macros
 +
 +On this page you can configure up to 10 keyboard macros to use in Edit sessions.
 +
 +Program Automation
 +
 +On this page you will find an assortment of options to help make using MARC Report more productve. You can associate a Windows File Type with MARC Report (so that you can run the program by doubleclicking on a file); choose a default Run mode (eg. so that doubleclicking a MARC file will always open it in the Editor); check whether there has been an update to MARC Report each time the program starts; use and configure the Cancelled Messages feature; and enable/disable MARC Help and MARC web links.
 +
 +Reset all Options
 +
 +If your program options have become hopelessly muddled, this option will clear the current options, and close the program. The next time you start the program it will open with the default set of options. Note: This 'reset' will not delete any customizations to files or tables; any local validation tables, cataloging check sets, mandatory field sets, cancelled message sets, local subject sets, etc., that you may have created will all remain unchanged. Also, before clearing the options file (called 'marcreport.ini' and stored in your 'My Documents\MarcReport' folder), a backup copy will be made called 'marcreport.ini-nnnn', where 'nnnn' represents an abbreviated form of the current date.
 +
 +
 +ENABLE OPTION PROFILES
 +
 +If this option is selected, MARC Report will enable support for option profiles the next time the program starts.
 +
 +A 'profile' is the collective name we give to most of the options that can be set on all of the pages or tabs of the option form. 
 +
 +The first step in creating a new profile is to save the current (default profile) using a different name. Once that is done, you can begin to customize the options in that profile.
 +
 +If option profiles are enabled, and if you have created any additional profiles, you can activate them from the main program menu: click Options, scroll down to the item 'Change profile', and select the options profile that you want to activate. Marc Report will then load those options, and will continue to use them until you change to another profile, or close the program.
 +
 +PROFILE NOTES
 +
 +Profiles do not use options that include file or folder names--these options are always taken from the primary .ini file, regardless of the profile in use. 
 +
 +Profiles do not include saved reviews, or any table that the user may have modified outside of the options form.
 +
 +MARC Report will always use the default profile when it is started.
 +
 +Unchecking 'Enable profiles' has no effect on any profiles already created. This action will simply disable the ability to create new option profiles, and/or use the 'Change Profile'.
 +
 +
 +THE UTILITIES OPTION (Alt-U)
 +
 +Run one of the MARC utilities that we have bundled with MARC Report. Currently, the available utilities are:
 +
 +Count Records: Quickly generate a count of the number of records in the currently selected file.
 +
 +Verify a file: Quickly process a file of MARC records and report on or remove any records with MARC records with MARC errors. 
 +
 +Split a file: Process a MARC file and split it into several smaller files, based on either the number of records or numbers of bytes specified.
 +
 +Concatenate files: join two or more MARC files into a single file.
 +
 +Export to Text: Quickly dump the selected MARC file to a tagged text format. Export is useful for getting a quick view of a file, and thus, prompts you to view the results after the first 100 records have been converted to text.
 +
 +Import from Text: Use this utility to import text records (such as the records from the LC online catalog, tagged text records created by Export above, records screen-scraped from other programs, records saved as text in Excel, etc) into MARC records that can be managed with MARC Report.
 +
 +MARC Analysis: generate comprehensive statistics about the MARC elements and data found in a file.
 +
 +MARC Sort: change the order of the records in a MARC file by sorting them on any MARC tag. You can also use MARC Sort to dedupe a MARC file.
 +
 +MARC Review: Search a MARC file for a particular pattern and create a customized report of the results (in either Text or MARC format, or both!)
 +
 +MARC Global: Run a global change on a file of records; you can delete a tag, delete a subfield, add a tag, add a subfield, copy a tag, copy a subfield, change a tag, subfield, or indicators, and change the data in a field.
 +
 +MARC21 to XML: Convert a file of MARC21 records to the XMLMARC format. The resulting file can then be viewed in XML-aware programs like Internet Explorer, XMLSpy, etc.
 +
 +XML to MARC21: Convert a file of XMLMARC records to the MARC21 format. The resulting file of records can then by managed in MARC Report.
 +
 +NOTE: For detailed information on any of the utilities (except for Count), please start the Utility and read the Help page found there.
 +
 +
 +SEARCH LC (Alt-L)
 +
 +Click this menu option to connect to the LC Online catalog (a good source of cataloging records that can be imported into MARC Report).
 +
 +
 +THE HELP MENU (Alt-H)
 +
 +Under the Help menu you will find the following items:
 +
 +Quick Steps: Instructions on how to start using MARC Report right away.
 +
 +Using the Main menu: (this Help page)
 +
 +How validation works in MARC Report: this help page describes the primary function of the program and how it is implemented.
 +
 +How to Import records from LC: a mini-tutorial on how to get records from the LC catalog into MARC Report
 +
 +Send Email to TMQ: Use this option to start an email message to TMQ.
 +
 +TMQ Website: This option browses to the TMQ website.
 +
 +TMQ Cataloging Workshops: Why? Because TMQ originated as a supplier of AACR and MARC training to catalogers and this is still a main part of our business (the other part being MARC Report, of course).
 +
 +MARC Report History: This option browses to a web page listing all recent versions of the program with detailed descriptions of the changes made in each.
 +
 +MARC Report Update: Use this option to see if a new version of MARC Report is available. The program is updated twice a year
 +
 +MARC Report Beta: Use this option to see if a beta version of MARC Report is available. Beta versions are constantly being produced.
 +
 +Register: Use this option to register your copy of MARC Report (or MARC Global)
 +
 +Tech Support Info: Use this option if requested by TMQ support; it will display important parameters of the program/installation.
 +
 +About: Use this option to see what version of MARC Report you are running.
 +
 +NOTE: MARC Report History, MARC Report Update, and MARC Report Beta options are available to registered users only.
  
phelp/helpmainmenu.txt · Last modified: 2013/06/18 11:35 (external edit)
Back to top
CC Attribution-Noncommercial-Share Alike 3.0 Unported
Driven by DokuWiki Recent changes RSS feed