Differences

This shows you the differences between two versions of the page.

Link to this comparison view

phelp:helpeditor [2013/02/10 14:14] (current)
Line 1: Line 1:
 +HOW TO USE THE MARC REPORT EDITOR
 +
 +This help page describes the functionality available during an 'Edit Session'. For a description of the validation features of the program, select the option called 'Validation in MARC Report' under the Help menu.
 +
 +GENERAL
 +
 +To use the MARC Report Editor, select a MARC file, then select the 'Edit Session' option from the File|Run menu.
 +
 +The records in the file will be validated, and can be navigated, in the same way as in a Record-by-Record run. The main difference will be a row of Editing buttons that appears along the bottom of the screen: Save, Undo, Delete.
 +
 +When you click on a brief message (top-right message window), the data element being reported as a problem is automatically selected in the MARC window. If the problem is in a Fixed field, the appropriate Fixed Field form will be displayed. This should make it very easy to correct problems reported by the program.
 +
 +The MARC record is always in edit mode. 
 +
 +To save a record that you have changed, you must press the Save button at the bottom of the screen.  To Undo ALL changes to a record, press the Undo Button. To Delete a record from the file, press the Delete button.
 +
 +If a record is changed and you do not save the record, the program will prompt you to save your changes when you try to move to another record.
 +
 +There is a default option that limits edit sessions by to files that are (approx.) 10,000 records or less. This limit can be increased by the user in the Edit Options.
 +
 +NAVIGATION
 +
 +Navigation works best using the mouse. 
 +
 +If you use the mouse to click somewhere in the record, you will be able to immediately begin editing. To change a tag, click on the tag and type the new tag number. To change an indicator value, click on the indicator and type the new value. To change the data in a tag, click on the data that you want to edit and begin typing. (When you click the data portion of a tag, the cursor is positioned at the point of the mouseclick.)
 +
 +If you prefer to use the keyboard to navigate, please take note of the following. 
 +
 +The program uses an (invisible) grid to display the MARC record. Therefore, the tag, indicator 1, indicator 2, and the data, are each stored in separate 'cells'. To navigate from one cell to the next using the keyboard, use the <Tab> key; use <Shift>+<Tab> to navigate backwards. Once you have navigated to the cell that you want to edit, press the <Enter> key to put that cell into 'edit mode'. Then, use the arrow keys to move to the position within the cell that you want to edit. When you are done editing the cell, press the <Esc> key to go back to 'navigation mode'; then you will be able to use the <Tab> key again to navigate around the record. 
 +
 +In a default Windows environment, you can tell whether you are in navigation mode or edit mode by the blue highlighting: in navigation mode, the entire cell is highlighted; in edit mode, only that part of the cell that contains data is highlighted.
 +
 +MARC SUBFIELD DELIMITER
 +
 +Press <Ctrl>D to insert the MARC subfield delimiter (which then should be followed by a subfield value). Press <F2> to insert a subfield delimiter and the subfield 'a'.  The display character representing the delimiter cannot be changed.  
 +
 +The symbol that the program uses for the subfield delimiter is , Ascii 177, a.k.a. the lowercase Polish 'el'. If this symbol is used in the MARC record, it will be enclosed in square brackets before the record is displayed in the editor. For example:
 +
 +aHaj[]asz, Piotr,d1966-
 +
 +If the record is changed and the 'Save' button is pressed, the program reads the record from the display, and converts it back to MARC. During this conversion, the square brackets are removed, so that 'Haj[]asz' becomes 'Hajasz'.
 +
 +TO DELETE A FIELD
 +
 +There are two ways to delete a field in the default view. First, clear the three digit tag from the first column, and then press Save.
 +
 +Alternately, click on the tag you wish to delete with your mouse and press <Ctrl><Delete>
 +
 +NOTE: Since the editor will not save a field that contains no data, you can also delete a field by deleting all of the data in the field and pressing Save.
 +
 +TO INSERT A FIELD
 +
 +Click the tag below which you want to insert a tag and press the <Insert> Key. This will insert a new field above the cursor. Type in the tag number, and then press TAB to go to the indicator(s) and data columns.
 +
 +To insert a Fixed Field (006-008), open the fixed field panel (if it is closed) and click on the Tag that you want to add: 006, 007, or 008. 
 +
 +In addition, if the record already has an 006, press <F6> to add another one; similarly, if the record already has an 007, press <F7> to add another one.
 +
 +In some cases, the program will try to guess at the correct template to display based on the leader. If the template that appears is not the one you want, select a template from the dropdown menu (at the top right of the fixed field panel)
 +
 +
 +TO INSERT A DIACRITIC
 +
 +Position your cursor in the record appropriately, then press <F3> to load the diacritic menu. The diacritic editor checks the Leader encoding byte (000/09) and then loads the appropriate set of diacritics (UTF-8, if 000/09='a', else MARC-8).
 +
 +Select the diacritic you want to insert and press Copy or Paste (or 'OK' in older versions). For MARC-8 diacritics, a preview of the diacritic will appear at the bottom of the diacritic editor. For UTF-8 diacritics, the code sequence will be displayed in hex. 
 +
 +To visually verify a UTF-8 diacritic, use the 'X view' (ie. XML View) after you have inserted the diacritic into the record.
 +
 +TO APPEND A FIELD TO THE END OF THE RECORD
 +
 +To append a new field to the end of the record, click on the last tag in the record and press the down arrow; then type the tag number and continue.
 +
 +SAVING AND DELETING
 +
 +To save a record that you have changed, press the Save button. Some changes (like deleting tags) are only evident after pressing the Save button, which also reformats and re-validates the record. Feel free to press Save whenever necessary.
 +
 +To undo the most recent edit, press the <Esc> key. Presently, the program does not support multiple levels of 'Undo'. However, you can completely restore any changed MARC record in an editing session: simply click the Undo button at the bottom of the screen. This will restore the record even if you have made changes, saved them, and gone on to edit other records.
 +
 +To remove a record from the file, click the Delete button.  Once deleted in this way, a record is no longer accessible in the Edit Session.  By default, all deleted records are saved to a file called 'DELETES.MRC' in the program work directory. Knowing this, an advanced user could easily create custom workfiles using the Delete button. 
 +
 +IMPORTANT: The only way to restore a deleted record to a file is to cancel the results of the Edit Session and start over with the original source file.
 +
 +EDITING FIXED FIELDS
 +
 +To edit a Fixed Field (000, 006, 007, 008), click on the the field (not the tag) in the edit window. This will open a Fixed Field form. Use the TAB key to move from one fixed field position to the next. Note that some Fixed Field positions in the leader are write-protected and may not be changed.
 +
 +To save changes made to a Fixed Field, press the <Enter> key or click the Save button on the fixed field form. To abandon changes, press the <Esc> key, or click the Cancel button. In either case, this action (Save or Cancel) will close the Fixed Field form and return to the full MARC display. 
 +
 +
 +DISPLAY OF LONG FIELDS THAT CONTAIN NO SPACES
 +
 +When the program encounters a long coded field that includes no blank spaces (like an 040, or local holdings tag), the line will not wrap normally. This is not an erroneous behavior. Simply click on the field to edit the data; you may need to use the arrow keys.
 +
 +
 +EDIT MENU OPTIONS 
 +
 +For a complete list of function keys available in the edit session, press <Ctrl><Alt>K
 +
 +DISPLAY LC VERSION OF A RECORD 
 +
 +If the record has an 010, switch to 'Related' record view. In this view the program presents the results of its attempt to fetch the matching record from the LC catalog using the Permalink service. If successful, the LC record will appear in a new window. 
 +
 +There are various display options available, but the most useful for our purposes is a tagged text display similar to that used in TEXT MODE. 
 +
 +You can quickly get a list of the main differences between your record and the DLC record by pressing the 'Compare' button. This runs a series of crosschecks on the two records and displays the differences at the top of the DLC display. 
 +
 +Note: If no LC records are accessed, even with what appear to be valid LCCNs, you should contact your tech support, as some local security policy may be blocking the program from connecting to the LC server.
 +
 +The records in the 'Related' view will automatically refresh when you navigate to another record.
 +
 +
 +DISPLAY CURRENT RECORD IN XML 
 +
 +If the record contains diacritics or unicode which do not display correctly in the MR window, switch to 'X View' (ie. XML View). In this view the record will be displayed as MARC XML (by default) using an Internet Explorer module, which provides complete unicode support. Note: If the record cannot be displayed, there may be an encoding error causing the MSXML to complain when it tried to render the record. You may send such records to us for analysis if you want more details.
 +
 +The XML view will automatically refresh when you navigate to another record.
 +
 +The XML view can be tailored to meet your needs by using the stylesheet option at the bottom of the page.
 +
 +
 +F8--COPY CURRENT RECORD TO CLIPBOARD AS TEXT
 +
 +This option will load the current record into the clipboard as tagged MARC text (the same format as our TEXT MODE uses). You can then use Paste to copy the record to another source, like an email or a Notepad window; or even back to MARC Report itself (see F9 below) as a way of quickly copying/cloning a record.
 +
 +
 +F9--IMPORT RECORD FROM CLIPBOARD
 +
 +This option will attempt to convert the contents of the clipboard to a MARC record, and then add that record to the end of the current file. Use this option to import records from the Library of Congress catalogs during a MARC Report Edit session, or to import tagged text records created by MARC Report in TEXT MODE (see F10 below) or by the EXPORT utility. You may import into any file you are editing, or create a new file using 'File|New Marc file' on the Main Menu.
 +
 +For a step-by-step tutorial on importing records from the LC Online Catalog, select the topic 'How to import records from LC' under the Help menu.
 +
 +The general steps to importing are: 
 + -Identify the record that you want to import
 + -Display the record in a MARC tagged format in your browser
 + -Copy the record to the Windows clipboard with <Ctrl>C
 + -Switch to your MARC Report Edit Session and press <F9>
 +
 +The record will be appended to the currently open file, and the program will move to the end of the file and position itself on the new record. 
 +
 +The import steps have been designed with the LC catalog and MARC Report in mind. They may work with other sources, but be careful: check the fixed fields carefully, as web browsers tend to concatenate multiple blanks spaces into a single blank space. Also, some sites do not display a leader in the MARC display.
 +
 +It is easy to make a copy of any MARC record when you are editing a file. Find the record that you wish to copy, then:
 + 1) Press F8, or select 'Copy Record to Clipboard' from the Edit menu
 + 2) Press F9, or select 'Import MARC Record' from the Edit menu
 +The record will be added to the end of the MARC file, and you will then be able to edit it. 
 +
 +You can also copy a record from one file to another in MARC Report. To copy a record into the file you are editing, start a new MARC Report session and open the second file in 'Record-by-Record' mode. Find the record you want to copy, press F8, then go back to your Edit session, and press F9.
 +
 +F10--ADD/APPEND RECORD TO ANOTHER MARC FILE
 +
 +Press F10 to add the current record to a MARC file. The record can be added to the end of an existing file, or a new file can be created. This option is useful to quickly create a file of records by navigating through a file in MARC Report and pressing F6 on each record that you want to extract. The result will be a MARC21 file that can be loaded into any MARC-aware software.
 +
 +
 +OPEN RECORD IN TEXT EDITOR (TEXT MODE)
 +
 +Switch to the 'Text view' tab on the left to view the current record in a Text editor. This mode is useful if you need to work with very long records, long fields of text (eg. 505), long fields without any blank spaces (eg. 9xx), or if  you want to quickly copy and paste large amounts of text. 
 +
 +For Help on using the 'Text Mode', read the Help page on the Text editor screen. 
 +
 +
 +F11--ADD NEW RECORD FROM TEMPLATE
 +
 +This option will open a navigation window where you can select a record from your Templates folder to add to the current file.
 +
 +Note that if you navigate outside of the template folder and select a MARC file the program will ignore the action.
 +
 +
 +F12--SAVE CURRENT RECORD AS TEMPLATE
 +
 +Press F12 to save the current record to your Templates folder.
 +
 +Note that if you navigate outside of the template folder and try to save the record the program will prompt you to go back to the Templates folder.
 +
 +
 +MACROS
 +
 +Macros can be defined in the program Options on the Edit Macros page. There are two types of macros: macros that create a new tag, and macros that paste constant data into the record. 
 +
 +See the help on the Edit Macros page for a description of how to create a macro.
 +
 +To use a macro to add a new tag, click on the tag immediately below where you want to insert the new tag, then press the corresponding ShortCut key. For example, if you have defined a macro for an 092 field, and the record you are working on looks like this--
 +
 +040     $aDLC$cDLC$dDLC$dNjBwBT
 +050 0 0 $aPS3606.L58$bE94 2006
 +082 0 0 $a813/.6$222
 +100 1   $aFlock, Elizabeth.
 +
 +--click on the 100 tag and then press the Shortcut key for your 092 macro. 
 +
 +To add a new tag to the end of the record, please follow these steps:
 +1) Click on the last tag in the record
 +2) Press the <Down Arrow> key once
 +3) Press <Enter>
 +4) Press the Shortcut that you have defined for your macro.
 +
 +NOTE: If you have the option to 'Sort Tags' enabled (under the Record Display options), then regardless of where a new tag is inserted by a macro (or by any other means), that tag will appear in numerical order as soon as the Save button is pressed.
 +
 +To add a constant data macro, simply click on the record at the point where you want to insert the data, then press the macro Shortcut key.
 +
 +IMPORTANT: Data created by using a macro while editing is not automatically saved; press the Save button to save any changes that result from macros.
 +
 +
 +WHAT THE PROGRAM CONSIDERS A CHANGE
 +
 +The program attempts to monitor what goes on with each record so that it can respond with an appropriate prompt, such as when you press a button like 'Save', or attempt to navigate away from an unsaved record. The program considers any keystroke to be a change; ergo, if you change something and change it back again, it does not realize the change was undone, and if you attempt to navigate away from the record, the program will prompt you to save it.
 +
 +Also, if you add a tag to a record, but do not add data to the field, the program will (by design) delete the 'empty tag' when you press 'Save'. So, if you are editing a template, for example, in order to enter a new tag, you will need to insert the tag, tab over to the data, and press <F2> to enter subfield $a (or some other subfield).
 +
 +Finally, if you add a record or records to a file using Import or Copy etc., and later delete each of these added records, when you exit the session, the program will respond that 'No changes...were made in the session'. This is because, internally, any record that is added to a session and later deleted is ignored by the processing that occurs when your Edit Session is saved.
 +
 +
 +ABOUT THE EDIT OPTIONS
 +
 +Please be sure that you also read the help under EDIT SESSIONS in the Program Options to learn how the editor in MARC Report saves records. It is important that you understand how these options work. If you have any questions, please do not hesitate to call or email us.
 +
 +
 +ABOUT THE EDIT SESSION IN GENERAL
 +
 +Whenever you edit a file with MARC Report, an 'Edit Session' is created. Each Edit Session is identified by a unique string that appears in the lower left-hand corner of the editor. 
 +
 +The format of this Edit Session Identifier is: 'S' + MMDD + '_' + 2 digits. 'MM' and 'DD' refer to the month and day of the Edit Session; the two digits at the end of the identifier are set to '01' at the beginning of each day, and increment by one each time an Edit Session is opened. 
 +
 +This Edit Session ID is used to create a folder on your hard disk (in the program 'WORK' directory) where all changed  MARC records are logged. In this folder you will also find:
 +  -a copy of the MARC source file that you began with (if your Edit options are set to 'Always rename to source')
 +  -a copy of the Edit results, before they are moved to the location specified in your Edit options
 +  -a file containing any records that were deleted (if your Edit options have set the 'Save deleted records')
 +
 +The following information about each Edit Session is automatically saved to a database that you can access via the Options (on the 'Edit Sessions' page): the name of the MARC source file, the name of the Results file, the number of records in the source file, the Session Identifier, Date, and Time of the Edit Session, the number of records edited, and the (sequential) record number of the last record that was edited.
 +
 +If you open an edit session and do not make any changes to the file, the program will erase all traces of the edit session when you exit. This is by design. (Thus, if, for example, you start a session just to make a titlelist, you will have to open the titlelist--from the 'View Reports' menu--then save the titlelist to another folder before exiting the session).
 +
 +EDITING VERY LARGE FILES WITH MARC REPORT
 +
 +In MARC Report we define a very large file as one that contains more than 100 MB (100,000,000 bytes). When working with very large files of MARC records in MARC Report, you should understand the following options.
 +
 +'How to Name the Edit Results'. If this option is set to 'Always rename to name of source' (the default), then the first thing MARC Report does when editing a file--once the file indexing completes--is to copy the source file to a backup folder. This operation can take a bit of time--depending on your system and the size of the file--and also use significant disk space. For example, if editing a 300MB MARC file (a library database of several hundred thousand records), then close MARC Report to take a break, when re-opening the file in MARC Report, a new Edit Session is begun--and the 300 MB file is backed up again to a new session folder. It does not overwrite the backup of the previous session. So there are now three copies of the file, using up about 1 GB of disk space: the file you started with (which we call the Source), the backup from the first session, and now a backup for the new session. 
 +
 +'How to Save Records'. If this option is set to 'Save changed and unchanged to the same file' (the default), then all records in the file are saved whether they are changed or not. This means that if you are editing a file of 300,000 records and just make two or three changes, all 300,000 records will still be saved to the Edit Results. Again, this uses up disk space and takes time. 
 +
 +'Clean Up Edit Work Files'. This option was designed to to automatically delete these backups at specified time intervals so that you can recover the disk space used during previous Edit Sessions. By default, the Clean-Up option is set to 'Weekly'--i.e. MARC Report will preserve (at most) one calendar week of backup sessions. Again, if you are working with a very large file for a few days, with the default options, the 'Weekly' setting is not going to be of much help. On the other hand, if you set the Clean-Up option to 'Daily', it means that any backup files will be deleted the next day that the program is started, which effectively negates the purpose of having a backup.
 +
 +The default settings for the options above are the optimum settings for the average MARC editing situation. You may also need to use these setting when editing very large files, depending on your objectives. If possible, however, we recommend the following settings when working with very large files:
 + 1) How to Save Records: "Changed records only".
 + 2) How to Name the Edit Results: "Prompt for a filename".
 + 3) Clean Up Edit Work files: "Weekly".
 +
 +KNOWN ISSUES (Not present in version 238 and later)
 +
 +1. When adding more than one line of text to a field, lines above the text being added may temporarily be invisible. Press the Up arrow to access these lines; or press the Save button to reformat the field (and make each line visible again). 
 +
 +2. Fields longer than 8192 bytes cannot be displayed in their entirety. When this situation arises, the program splits the field into two pieces (using the MARC specification defined for this purpose: control subfield $8, Field link and sequence number (http://www.loc.gov/marc/bibliographic/ecbdcntf.html). If the record is later modified, the two pieces of the field will be re-joined when the final Edit Results are generated.
  
phelp/helpeditor.txt · Last modified: 2013/02/10 14:14 (external edit)
Back to top
CC Attribution-Noncommercial-Share Alike 3.0 Unported
Driven by DokuWiki Recent changes RSS feed